Back to overview
Downtime

Neville Holt, Launde - Abbey Farm, and 22 other services are down

May 21, 2026 at 4:45pm UTC
Affected services
Neville Holt
Launde - Abbey Farm
Goadby
Launde - Copt Hill
Braunston - Ladywood
Braunston - The Wisp
South Croxton
Lowesby
Twyford
Braunston
Somerby / Owston
Shangton North
Ridlington
Owston
Gaulby
Billesdon Coplow
Tilton on the Hill
Houghton on the Hill
Illston on the Hill
Twyford South
Loddington
Shangton Care Village
Core South (Skeffington)
Core North (Whatborough Hill)

Resolved
May 21, 2026 at 4:53pm UTC

Neville Holt recovered.

Updated
May 21, 2026 at 4:52pm UTC

Goadby, Braunston - Ladywood, Braunston, and 4 other resources recovered.

Updated
May 21, 2026 at 4:52pm UTC

Launde - Abbey Farm, Launde - Copt Hill, Braunston - The Wisp, and 8 other resources recovered.

Updated
May 21, 2026 at 4:52pm UTC

South Croxton, Lowesby, Owston, and 1 other resource recovered.

Updated
May 21, 2026 at 4:51pm UTC

Core South (Skeffington) recovered.

Created
May 21, 2026 at 4:45pm UTC

Neville Holt, Launde - Abbey Farm, Goadby, and 21 other resources went down.