Back to overview
Downtime

Gaulby, Billesdon Coplow, and 2 other services are down

Dec 5, 2025 at 4:44pm UTC
Affected services
Gaulby
Billesdon Coplow
Houghton on the Hill
Illston on the Hill

Resolved
Dec 5, 2025 at 5:29pm UTC

HERBS - Gaulby, HERBS - Billesdon Coplow, HERBS - Houghton on the Hill, and 1 other resource recovered.

Updated
Dec 5, 2025 at 5:28pm UTC

HERBS - Gaulby, HERBS - Billesdon Coplow, HERBS - Houghton on the Hill, and 1 other resource went down.

Updated
Dec 5, 2025 at 4:49pm UTC

HERBS - Gaulby, HERBS - Billesdon Coplow, HERBS - Houghton on the Hill, and 1 other resource recovered.

Created
Dec 5, 2025 at 4:44pm UTC

HERBS - Gaulby, HERBS - Billesdon Coplow, HERBS - Houghton on the Hill, and 1 other resource went down.